const regex = /(?i)\..*? (?P<error>\w+)(?= )/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\..*? (?P<error>\\w+)(?= )', '')
const str = `2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}