use strict;
my $str = '2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:';
my $regex = qr/(?i)\..*? (?P<error>\w+)(?= )/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}