using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\..*? (?P<error>\w+)(?= )";
string input = @"2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}