$re = '/(?i)\..*? (?P<error>\w+)(?= )/';
$str = '2014-09-12 03:25:16.549: org.eclipse.jetty.server.AsyncHttpConnection WARN - Closing EndPoint making no progress:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);