import Foundation
let pattern = #"^(.+?)\ *=\ *(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##############################################################"""
#INFOFILE1.1 - Do not remove this line!
FileIdent = CarMaker-Plugins 1
FileCreator = CarMaker 2014-12-18 08:00:00
## Plugins #############################################################
VehicleControl.ZMS = 1
VehicleControl.ZMS.Info = ZMS
Brake.MyBrake_FMU = 1
Brake.MyBrake_FMU.Info = MyBrake_FMU
PTClutch.MyClutch_FMU = 1
PTClutch.MyClutch_FMU.Info = MyClutch_FMU
VehicleControl.MyVehicleControl_FMU = 1
VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU
"""##############################################################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)