// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+?)\ *=\ *(.*)").unwrap();
let string = "#INFOFILE1.1 - Do not remove this line!
FileIdent = CarMaker-Plugins 1
FileCreator = CarMaker 2014-12-18 08:00:00
## Plugins #############################################################
VehicleControl.ZMS = 1
VehicleControl.ZMS.Info = ZMS
Brake.MyBrake_FMU = 1
Brake.MyBrake_FMU.Info = MyBrake_FMU
PTClutch.MyClutch_FMU = 1
PTClutch.MyClutch_FMU.Info = MyClutch_FMU
VehicleControl.MyVehicleControl_FMU = 1
VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}