import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)\\ *=\\ *(.*)";
final String string = "#INFOFILE1.1 - Do not remove this line!\n"
+ "FileIdent = CarMaker-Plugins 1\n"
+ "FileCreator = CarMaker 2014-12-18 08:00:00\n\n\n"
+ "## Plugins #############################################################\n"
+ "VehicleControl.ZMS = 1\n"
+ "VehicleControl.ZMS.Info = ZMS\n"
+ "Brake.MyBrake_FMU = 1\n"
+ "Brake.MyBrake_FMU.Info = MyBrake_FMU\n"
+ "PTClutch.MyClutch_FMU = 1\n"
+ "PTClutch.MyClutch_FMU.Info = MyClutch_FMU\n"
+ "VehicleControl.MyVehicleControl_FMU = 1\n"
+ "VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}