using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)\ *=\ *(.*)";
string input = @"#INFOFILE1.1 - Do not remove this line!
FileIdent = CarMaker-Plugins 1
FileCreator = CarMaker 2014-12-18 08:00:00
## Plugins #############################################################
VehicleControl.ZMS = 1
VehicleControl.ZMS.Info = ZMS
Brake.MyBrake_FMU = 1
Brake.MyBrake_FMU.Info = MyBrake_FMU
PTClutch.MyClutch_FMU = 1
PTClutch.MyClutch_FMU.Info = MyClutch_FMU
VehicleControl.MyVehicleControl_FMU = 1
VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}