#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+?)\ *=\ *(.*)"
Local $sString = "#INFOFILE1.1 - Do not remove this line!" & @CRLF & _
"FileIdent = CarMaker-Plugins 1" & @CRLF & _
"FileCreator = CarMaker 2014-12-18 08:00:00" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## Plugins #############################################################" & @CRLF & _
"VehicleControl.ZMS = 1" & @CRLF & _
"VehicleControl.ZMS.Info = ZMS" & @CRLF & _
"Brake.MyBrake_FMU = 1" & @CRLF & _
"Brake.MyBrake_FMU.Info = MyBrake_FMU" & @CRLF & _
"PTClutch.MyClutch_FMU = 1" & @CRLF & _
"PTClutch.MyClutch_FMU.Info = MyClutch_FMU" & @CRLF & _
"VehicleControl.MyVehicleControl_FMU = 1" & @CRLF & _
"VehicleControl.MyVehicleControl_FMU.Info = MyVehicleControl_FMU"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")