import Foundation
let pattern = #"(?P<first_part>(?:ifstream|ofstream)\s+[0-9a-zA-z_]+\s*\()(?:\"(?P<file_name>[0-9a-zA-z_.]+)\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
ifstream f1("text1.txt");
ifstream f2 ("text2.txt");
ifstream f_ASFdf1("text1");
ofstream out ("output.txt");//создали объект и сразу же открыли файл для записи
ofstream of;//создали объект класса
of.open("test.txt");//открыли файл для записи
ofstream of("test.txt", ios_base::app); //добавление информации к концу файла
ofstream of("test.txt", ios_base::trunc); //очистить содержимое файла
ofstream of("test.txt", ios_base::binary); //открыть в бинарном режиме
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)