use strict;
my $str = 'ifstream f1("text1.txt");
ifstream f2 ("text2.txt");
ifstream f_ASFdf1("text1");
ofstream out ("output.txt");//создали объект и сразу же открыли файл для записи
ofstream of;//создали объект класса
of.open("test.txt");//открыли файл для записи
ofstream of("test.txt", ios_base::app); //добавление информации к концу файла
ofstream of("test.txt", ios_base::trunc); //очистить содержимое файла
ofstream of("test.txt", ios_base::binary); //открыть в бинарном режиме';
my $regex = qr/(?P<first_part>(?:ifstream|ofstream)\s+[0-9a-zA-z_]+\s*\()(?:\"(?P<file_name>[0-9a-zA-z_.]+)\")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}