#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?P<first_part>(?:ifstream|ofstream)\s+[0-9a-zA-z_]+\s*\()(?:\"(?P<file_name>[0-9a-zA-z_.]+)\")"
Local $sString = "ifstream f1("text1.txt");" & @CRLF & _
" ifstream f2 ("text2.txt");" & @CRLF & _
"" & @CRLF & _
"ifstream f_ASFdf1("text1");" & @CRLF & _
"" & @CRLF & _
" ofstream out ("output.txt");//создали объект и сразу же открыли файл для записи" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ofstream of;//создали объект класса" & @CRLF & _
"of.open("test.txt");//открыли файл для записи" & @CRLF & _
"" & @CRLF & _
"ofstream of("test.txt", ios_base::app); //добавление информации к концу файла" & @CRLF & _
"ofstream of("test.txt", ios_base::trunc); //очистить содержимое файла" & @CRLF & _
"ofstream of("test.txt", ios_base::binary); //открыть в бинарном режиме"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")