re = /(?P<first_part>(?:ifstream|ofstream)\s+[0-9a-zA-z_]+\s*\()(?:\"(?P<file_name>[0-9a-zA-z_.]+)\")/
str = 'ifstream f1("text1.txt");
ifstream f2 ("text2.txt");
ifstream f_ASFdf1("text1");
ofstream out ("output.txt");//создали объект и сразу же открыли файл для записи
ofstream of;//создали объект класса
of.open("test.txt");//открыли файл для записи
ofstream of("test.txt", ios_base::app); //добавление информации к концу файла
ofstream of("test.txt", ios_base::trunc); //очистить содержимое файла
ofstream of("test.txt", ios_base::binary); //открыть в бинарном режиме'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end