# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<first_part>(?:ifstream|ofstream)\s+[0-9a-zA-z_]+\s*\()(?:\"(?P<file_name>[0-9a-zA-z_.]+)\")"
test_str = ("ifstream f1(\"text1.txt\");\n"
" ifstream f2 (\"text2.txt\");\n\n"
"ifstream f_ASFdf1(\"text1\");\n\n"
" ofstream out (\"output.txt\");//создали объект и сразу же открыли файл для записи\n\n\n"
"ofstream of;//создали объект класса\n"
"of.open(\"test.txt\");//открыли файл для записи\n\n"
"ofstream of(\"test.txt\", ios_base::app); //добавление информации к концу файла\n"
"ofstream of(\"test.txt\", ios_base::trunc); //очистить содержимое файла\n"
"ofstream of(\"test.txt\", ios_base::binary); //открыть в бинарном режиме")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.