import Foundation
let pattern = #"([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!".*?")([^\{\[\r\n]*?)([,\]\}])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"bla":12.0,
"bla":+12.0,
"bla":-12.0,
"bla":+12,
"bla":false,
"bla":true,
"bla":+12.0.0,
"bla":"string",
"bla":path,
"bla":pathWith0.2,
"bla":,
"bla":{"inner":false,"bli":"s","blu":path},
"bla":[path1,path2,path3},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"$2"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)