# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!".*?")([^\{\[\r\n]*?)([,\]\}])/$1"$2"$3/g;t' <<< "\"bla\":12.0,
\"bla\":+12.0,
\"bla\":-12.0,
\"bla\":+12,
\"bla\":false,
\"bla\":true,
\"bla\":+12.0.0,
\"bla\":\"string\",
\"bla\":path,
\"bla\":pathWith0.2,
\"bla\":,
\"bla\":{\"inner\":false,\"bli\":\"s\",\"blu\":path},
\"bla\":[path1,path2,path3},
"