import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([:\\[,])(?![+-]?\\d+\\.?\\d*)(?!false|true)(?!\".*?\")([^\\{\\[\\r\\n]*?)([,\\]\\}])";
final String string = "\"bla\":12.0,\n"
+ "\"bla\":+12.0,\n"
+ "\"bla\":-12.0,\n"
+ "\"bla\":+12,\n"
+ "\"bla\":false,\n"
+ "\"bla\":true,\n"
+ "\"bla\":+12.0.0,\n"
+ "\"bla\":\"string\",\n"
+ "\"bla\":path,\n"
+ "\"bla\":pathWith0.2,\n"
+ "\"bla\":,\n"
+ "\"bla\":{\"inner\":false,\"bli\":\"s\",\"blu\":path},\n"
+ "\"bla\":[path1,path2,path3},\n";
final String subst = "$1\"$2\"$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}