const regex = /([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!".*?")([^\{\[\r\n]*?)([,\]\}])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([:\\[,])(?![+-]?\\d+\\.?\\d*)(?!false|true)(?!".*?")([^\\{\\[\\r\\n]*?)([,\\]\\}])', 'g')
const str = `"bla":12.0,
"bla":+12.0,
"bla":-12.0,
"bla":+12,
"bla":false,
"bla":true,
"bla":+12.0.0,
"bla":"string",
"bla":path,
"bla":pathWith0.2,
"bla":,
"bla":{"inner":false,"bli":"s","blu":path},
"bla":[path1,path2,path3},
`;
const subst = `$1"$2"$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);