$re = '/([:\[,])(?![+-]?\d+\.?\d*)(?!false|true)(?!".*?")([^\{\[\r\n]*?)([,\]\}])/';
$str = '"bla":12.0,
"bla":+12.0,
"bla":-12.0,
"bla":+12,
"bla":false,
"bla":true,
"bla":+12.0.0,
"bla":"string",
"bla":path,
"bla":pathWith0.2,
"bla":,
"bla":{"inner":false,"bli":"s","blu":path},
"bla":[path1,path2,path3},
';
$subst = "$1\"$2\"$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;