import Foundation
let pattern = #"class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn("|([^(a-z|A-Z|0-9|\-|_)]).*")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="tel:{{ message.contact_phone }}" data-message-phone-btn class="bottom-bar__btn"><i class="mypro-icon mypro-icon-phone"></i><br>{{ _("Appeler") }}</a>
<a href="sms:{{ message.contact_phone }}&body={{ body|urlencode }}" data-message-sms-btn class="bottom-bar__btn hide-for-medium-up"><i class="mypro-icon mypro-icon-sms"></i><br>{{ _("SMS") }}</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)