// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn("|([^(a-z|A-Z|0-9|\-|_)]).*")"#).unwrap();
let string = " <a href=\"tel:{{ message.contact_phone }}\" data-message-phone-btn class=\"bottom-bar__btn\"><i class=\"mypro-icon mypro-icon-phone\"></i><br>{{ _(\"Appeler\") }}</a>
<a href=\"sms:{{ message.contact_phone }}&body={{ body|urlencode }}\" data-message-sms-btn class=\"bottom-bar__btn hide-for-medium-up\"><i class=\"mypro-icon mypro-icon-sms\"></i><br>{{ _(\"SMS\") }}</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}