using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn(""|([^(a-z|A-Z|0-9|\-|_)]).*"")";
string input = @" <a href=""tel:{{ message.contact_phone }}"" data-message-phone-btn class=""bottom-bar__btn""><i class=""mypro-icon mypro-icon-phone""></i><br>{{ _(""Appeler"") }}</a>
<a href=""sms:{{ message.contact_phone }}&body={{ body|urlencode }}"" data-message-sms-btn class=""bottom-bar__btn hide-for-medium-up""><i class=""mypro-icon mypro-icon-sms""></i><br>{{ _(""SMS"") }}</a>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}