const regex = /class=([^=]*)([^(a-z|A-Z|0-9|\-|_)])btn("|([^(a-z|A-Z|0-9|\-|_)]).*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class=([^=]*)([^(a-z|A-Z|0-9|\\-|_)])btn("|([^(a-z|A-Z|0-9|\\-|_)]).*")', 'g')
const str = ` <a href="tel:{{ message.contact_phone }}" data-message-phone-btn class="bottom-bar__btn"><i class="mypro-icon mypro-icon-phone"></i><br>{{ _("Appeler") }}</a>
<a href="sms:{{ message.contact_phone }}&body={{ body|urlencode }}" data-message-sms-btn class="bottom-bar__btn hide-for-medium-up"><i class="mypro-icon mypro-icon-sms"></i><br>{{ _("SMS") }}</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}