import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=([^=]*)([^(a-z|A-Z|0-9|\\-|_)])btn(\"|([^(a-z|A-Z|0-9|\\-|_)]).*\")";
final String string = " <a href=\"tel:{{ message.contact_phone }}\" data-message-phone-btn class=\"bottom-bar__btn\"><i class=\"mypro-icon mypro-icon-phone\"></i><br>{{ _(\"Appeler\") }}</a>\n"
+ " <a href=\"sms:{{ message.contact_phone }}&body={{ body|urlencode }}\" data-message-sms-btn class=\"bottom-bar__btn hide-for-medium-up\"><i class=\"mypro-icon mypro-icon-sms\"></i><br>{{ _(\"SMS\") }}</a>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}