re = /(?<=displayImportingConfirmationMessage\(').*(?<=})/
str = '<script>parent.displayImportingConfirmationMessage(\'{"temporaryZipFile":"/opt/fluig/volume/upload/adm/pageImport/pageUpload2572076996793369742WCMPageExport.zip","expandedDirectoryZipFile":"/opt/fluig/volume/upload/adm/pageImport/expandedPage_3205464082306670499","itemName":"WCMPageExport.zip","isItemFormField":false,"pages":[{"title":"Home","description":"Home","pageKey":{"code":"home"},"displayOrder":10,"childrens":[],"enabledChildren":false,"enabledPathParam":false,"enabledMobileApp":false,"editable":true,"disableChildLevel":false,"menuGroup":false,"iconUploaded":false,"hidden":false,"enabled":true,"opened":false,"depthLevel":-1,"preferences":{}}]}\');</script>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end