import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=displayImportingConfirmationMessage\\(').*(?<=\\})";
final String string = "<script>parent.displayImportingConfirmationMessage('{\"temporaryZipFile\":\"/opt/fluig/volume/upload/adm/pageImport/pageUpload2572076996793369742WCMPageExport.zip\",\"expandedDirectoryZipFile\":\"/opt/fluig/volume/upload/adm/pageImport/expandedPage_3205464082306670499\",\"itemName\":\"WCMPageExport.zip\",\"isItemFormField\":false,\"pages\":[{\"title\":\"Home\",\"description\":\"Home\",\"pageKey\":{\"code\":\"home\"},\"displayOrder\":10,\"childrens\":[],\"enabledChildren\":false,\"enabledPathParam\":false,\"enabledMobileApp\":false,\"editable\":true,\"disableChildLevel\":false,\"menuGroup\":false,\"iconUploaded\":false,\"hidden\":false,\"enabled\":true,\"opened\":false,\"depthLevel\":-1,\"preferences\":{}}]}');</script>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}