const regex = /(?<=displayImportingConfirmationMessage\(').*(?<=})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=displayImportingConfirmationMessage\\(\').*(?<=})', 'g')
const str = `<script>parent.displayImportingConfirmationMessage('{"temporaryZipFile":"/opt/fluig/volume/upload/adm/pageImport/pageUpload2572076996793369742WCMPageExport.zip","expandedDirectoryZipFile":"/opt/fluig/volume/upload/adm/pageImport/expandedPage_3205464082306670499","itemName":"WCMPageExport.zip","isItemFormField":false,"pages":[{"title":"Home","description":"Home","pageKey":{"code":"home"},"displayOrder":10,"childrens":[],"enabledChildren":false,"enabledPathParam":false,"enabledMobileApp":false,"editable":true,"disableChildLevel":false,"menuGroup":false,"iconUploaded":false,"hidden":false,"enabled":true,"opened":false,"depthLevel":-1,"preferences":{}}]}');</script>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}