use strict;
my $str = '<script>parent.displayImportingConfirmationMessage(\'{"temporaryZipFile":"/opt/fluig/volume/upload/adm/pageImport/pageUpload2572076996793369742WCMPageExport.zip","expandedDirectoryZipFile":"/opt/fluig/volume/upload/adm/pageImport/expandedPage_3205464082306670499","itemName":"WCMPageExport.zip","isItemFormField":false,"pages":[{"title":"Home","description":"Home","pageKey":{"code":"home"},"displayOrder":10,"childrens":[],"enabledChildren":false,"enabledPathParam":false,"enabledMobileApp":false,"editable":true,"disableChildLevel":false,"menuGroup":false,"iconUploaded":false,"hidden":false,"enabled":true,"opened":false,"depthLevel":-1,"preferences":{}}]}\');</script>
';
my $regex = qr/(?<=displayImportingConfirmationMessage\(').*(?<=})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}