use strict;
my $str = '(554) 555 55 55';
my $regex = qr/(554) 555 55 55/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";