# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(554) 555 55 55//;t' <<< "(554) 555 55 55"