// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]{2,})\/([A-Za-z]{2,})\/([A-Z]{2}-\d{4,})[\/\-\_\ ]([\w\-\ ]*)$").unwrap();
let string = "ft/rb/FE-5623/Do_stuff_that_15_awe-some
ft/rb/FE-5623/Do stuff that 15 awe-some
ft/rb/FE-5623_Do stuff that 15 awe-some
ft/rb/FE-5623-Do stuff that 15 awe-some
ft/rb/FE-5623 Do stuff that 15 awe-some
not at all
f_t/rb/FE-5623-Do stuff that 15 awe-some
ft/r_b/FE-5623-Do stuff that 15 awe-some
ft/rb/FE_5623-Do stuff that 15 awe-some
FE-5623/not_quite
ft/rb/FE-5623/Do_stuff_that_!! not really
_azeaze
azea_zae";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}