#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Za-z]{2,})\/([A-Za-z]{2,})\/([A-Z]{2}-\d{4,})[\/\-\_\ ]([\w\-\ ]*)$"
Local $sString = "ft/rb/FE-5623/Do_stuff_that_15_awe-some" & @CRLF & _
"ft/rb/FE-5623/Do stuff that 15 awe-some" & @CRLF & _
"ft/rb/FE-5623_Do stuff that 15 awe-some" & @CRLF & _
"ft/rb/FE-5623-Do stuff that 15 awe-some" & @CRLF & _
"ft/rb/FE-5623 Do stuff that 15 awe-some" & @CRLF & _
"not at all" & @CRLF & _
"f_t/rb/FE-5623-Do stuff that 15 awe-some" & @CRLF & _
"ft/r_b/FE-5623-Do stuff that 15 awe-some" & @CRLF & _
"ft/rb/FE_5623-Do stuff that 15 awe-some" & @CRLF & _
"FE-5623/not_quite" & @CRLF & _
"ft/rb/FE-5623/Do_stuff_that_!! not really" & @CRLF & _
"_azeaze" & @CRLF & _
"azea_zae"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")