import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z]{2,})\\/([A-Za-z]{2,})\\/([A-Z]{2}-\\d{4,})[\\/\\-\\_\\ ]([\\w\\-\\ ]*)$";
final String string = "ft/rb/FE-5623/Do_stuff_that_15_awe-some\n"
+ "ft/rb/FE-5623/Do stuff that 15 awe-some\n"
+ "ft/rb/FE-5623_Do stuff that 15 awe-some\n"
+ "ft/rb/FE-5623-Do stuff that 15 awe-some\n"
+ "ft/rb/FE-5623 Do stuff that 15 awe-some\n"
+ "not at all\n"
+ "f_t/rb/FE-5623-Do stuff that 15 awe-some\n"
+ "ft/r_b/FE-5623-Do stuff that 15 awe-some\n"
+ "ft/rb/FE_5623-Do stuff that 15 awe-some\n"
+ "FE-5623/not_quite\n"
+ "ft/rb/FE-5623/Do_stuff_that_!! not really\n"
+ "_azeaze\n"
+ "azea_zae";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}