const regex = /^([A-Za-z]{2,})\/([A-Za-z]{2,})\/([A-Z]{2}-\d{4,})[\/\-\_\ ]([\w\-\ ]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z]{2,})\\\/([A-Za-z]{2,})\\\/([A-Z]{2}-\\d{4,})[\\\/\\-\\_\\ ]([\\w\\-\\ ]*)$', 'gm')
const str = `ft/rb/FE-5623/Do_stuff_that_15_awe-some
ft/rb/FE-5623/Do stuff that 15 awe-some
ft/rb/FE-5623_Do stuff that 15 awe-some
ft/rb/FE-5623-Do stuff that 15 awe-some
ft/rb/FE-5623 Do stuff that 15 awe-some
not at all
f_t/rb/FE-5623-Do stuff that 15 awe-some
ft/r_b/FE-5623-Do stuff that 15 awe-some
ft/rb/FE_5623-Do stuff that 15 awe-some
FE-5623/not_quite
ft/rb/FE-5623/Do_stuff_that_!! not really
_azeaze
azea_zae`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}