using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z]{2,})\/([A-Za-z]{2,})\/([A-Z]{2}-\d{4,})[\/\-\_\ ]([\w\-\ ]*)$";
string input = @"ft/rb/FE-5623/Do_stuff_that_15_awe-some
ft/rb/FE-5623/Do stuff that 15 awe-some
ft/rb/FE-5623_Do stuff that 15 awe-some
ft/rb/FE-5623-Do stuff that 15 awe-some
ft/rb/FE-5623 Do stuff that 15 awe-some
not at all
f_t/rb/FE-5623-Do stuff that 15 awe-some
ft/r_b/FE-5623-Do stuff that 15 awe-some
ft/rb/FE_5623-Do stuff that 15 awe-some
FE-5623/not_quite
ft/rb/FE-5623/Do_stuff_that_!! not really
_azeaze
azea_zae";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}