$re = '/\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]/i';
$str = 'afrawefaew = $_REQUEST[\'foo\']
sfvdfvsdfv=$_REQUEST[\'foo\']
sdfvsdfv =$_REQUEST[\'barbar\']
sdfvsdfv= $_REQUEST[\'baz\']
sdfsdv == $_REQUEST[\'123sgrtrthrsh\']
$_GET[\'foo\']
$_GET[\'barbar\']
$_get[\'baz\']
$_POST[\'123sgrtrthrsh\']
$_post[\'123sgrtrthrsh\']
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);