#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]"
Local $sString = "afrawefaew = $_REQUEST['foo']" & @CRLF & _
"sfvdfvsdfv=$_REQUEST['foo']" & @CRLF & _
"sdfvsdfv =$_REQUEST['barbar']" & @CRLF & _
"sdfvsdfv= $_REQUEST['baz']" & @CRLF & _
"sdfsdv == $_REQUEST['123sgrtrthrsh']" & @CRLF & _
"" & @CRLF & _
"$_GET['foo']" & @CRLF & _
"$_GET['barbar']" & @CRLF & _
"$_get['baz']" & @CRLF & _
"$_POST['123sgrtrthrsh']" & @CRLF & _
"$_post['123sgrtrthrsh']" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")