use strict;
my $str = 'afrawefaew = $_REQUEST[\'foo\']
sfvdfvsdfv=$_REQUEST[\'foo\']
sdfvsdfv =$_REQUEST[\'barbar\']
sdfvsdfv= $_REQUEST[\'baz\']
sdfsdv == $_REQUEST[\'123sgrtrthrsh\']
$_GET[\'foo\']
$_GET[\'barbar\']
$_get[\'baz\']
$_POST[\'123sgrtrthrsh\']
$_post[\'123sgrtrthrsh\']
';
my $regex = qr/\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}