using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]";
string input = @"afrawefaew = $_REQUEST['foo']
sfvdfvsdfv=$_REQUEST['foo']
sdfvsdfv =$_REQUEST['barbar']
sdfvsdfv= $_REQUEST['baz']
sdfsdv == $_REQUEST['123sgrtrthrsh']
$_GET['foo']
$_GET['barbar']
$_get['baz']
$_POST['123sgrtrthrsh']
$_post['123sgrtrthrsh']
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}