const regex = /\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUEST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_POST\[.*\]|\s*(?=(\=(?!\=)))((?<!\=)\=)\s*\$_REQUET\[.*\]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_REQUEST\\[.*\\]|\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_POST\\[.*\\]|\\s*(?=(\\=(?!\\=)))((?<!\\=)\\=)\\s*\\$_REQUET\\[.*\\]', 'gi')
const str = `afrawefaew = \$_REQUEST['foo']
sfvdfvsdfv=\$_REQUEST['foo']
sdfvsdfv =\$_REQUEST['barbar']
sdfvsdfv= \$_REQUEST['baz']
sdfsdv == \$_REQUEST['123sgrtrthrsh']
\$_GET['foo']
\$_GET['barbar']
\$_get['baz']
\$_POST['123sgrtrthrsh']
\$_post['123sgrtrthrsh']
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}