// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})").unwrap();
let string = "netstat -anob
netstat -ano
netstat -anob
netstat -ano
netstat /anob
netstat /ano
netstat /anob
netstat /ano
netstat/anob
netstat/ano
netstat /anob
netstat /ano
netstat -a
netstat -an
netstat /a
netstat /an
netstat /ona
netstat /bona
netstat /nob
netstat /noba
netstat /onab
netstat /noba
netstat /abon
netstat /abn
netstat /anb
netstat-anob
netstat-ano
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}