#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})"
Local $sString = "netstat -anob" & @CRLF & _
"netstat -ano" & @CRLF & _
"netstat -anob" & @CRLF & _
"netstat -ano" & @CRLF & _
"netstat /anob" & @CRLF & _
"netstat /ano" & @CRLF & _
"netstat /anob" & @CRLF & _
"netstat /ano" & @CRLF & _
"netstat/anob" & @CRLF & _
"netstat/ano" & @CRLF & _
" netstat /anob" & @CRLF & _
" netstat /ano" & @CRLF & _
"netstat -a" & @CRLF & _
"netstat -an" & @CRLF & _
"netstat /a" & @CRLF & _
"netstat /an" & @CRLF & _
"netstat /ona" & @CRLF & _
"netstat /bona" & @CRLF & _
"netstat /nob" & @CRLF & _
"netstat /noba" & @CRLF & _
"netstat /onab" & @CRLF & _
"netstat /noba" & @CRLF & _
"netstat /abon" & @CRLF & _
"netstat /abn" & @CRLF & _
"netstat /anb" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"netstat-anob" & @CRLF & _
"netstat-ano" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")