const regex = /(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(netstat\\s*\\\/(a|n|o|b){1,4})|(netstat\\s+-(a|n|o|b){1,4})', 'gm')
const str = `netstat -anob
netstat -ano
netstat -anob
netstat -ano
netstat /anob
netstat /ano
netstat /anob
netstat /ano
netstat/anob
netstat/ano
netstat /anob
netstat /ano
netstat -a
netstat -an
netstat /a
netstat /an
netstat /ona
netstat /bona
netstat /nob
netstat /noba
netstat /onab
netstat /noba
netstat /abon
netstat /abn
netstat /anb
netstat-anob
netstat-ano
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}