$re = '/(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})/m';
$str = 'netstat -anob
netstat -ano
netstat -anob
netstat -ano
netstat /anob
netstat /ano
netstat /anob
netstat /ano
netstat/anob
netstat/ano
netstat /anob
netstat /ano
netstat -a
netstat -an
netstat /a
netstat /an
netstat /ona
netstat /bona
netstat /nob
netstat /noba
netstat /onab
netstat /noba
netstat /abon
netstat /abn
netstat /anb
netstat-anob
netstat-ano
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);