import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(netstat\\s*\\/(a|n|o|b){1,4})|(netstat\\s+-(a|n|o|b){1,4})";
final String string = "netstat -anob\n"
+ "netstat -ano\n"
+ "netstat -anob\n"
+ "netstat -ano\n"
+ "netstat /anob\n"
+ "netstat /ano\n"
+ "netstat /anob\n"
+ "netstat /ano\n"
+ "netstat/anob\n"
+ "netstat/ano\n"
+ " netstat /anob\n"
+ " netstat /ano\n"
+ "netstat -a\n"
+ "netstat -an\n"
+ "netstat /a\n"
+ "netstat /an\n"
+ "netstat /ona\n"
+ "netstat /bona\n"
+ "netstat /nob\n"
+ "netstat /noba\n"
+ "netstat /onab\n"
+ "netstat /noba\n"
+ "netstat /abon\n"
+ "netstat /abn\n"
+ "netstat /anb\n\n\n\n"
+ "netstat-anob\n"
+ "netstat-ano\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}