import Foundation
let pattern = #"(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1¿$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)