const regex = new RegExp('(^|[\\.\\?\\!\\-]\\s|)([A-ZÃ-ÚÑ][^¿¡\\!\\?\\.]+)((\\.{3})?\\?)', 'g')
const str = `Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?`;
const subst = `$1¿$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);