import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[\\.\\?\\!\\-]\\s|)([A-ZÃ-ÚÑ][^¿¡\\!\\?\\.]+)((\\.{3})?\\?)";
final String string = "Qué dices? Eso es...? No entiendo.\n"
+ "Adrian y Pedro lo saben? - SÃ, no lo sabÃas?";
final String subst = "$1¿$2$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}