$re = '/(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)/';
$str = 'Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?';
$subst = "$1¿$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;