package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[\.\?\!\-]\s|)([A-ZÃ-ÚÑ][^¿¡\!\?\.]+)((\.{3})?\?)`)
var str = `Qué dices? Eso es...? No entiendo.
Adrian y Pedro lo saben? - SÃ, no lo sabÃas?`
var substitution = "$1¿$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}